XStandard WYSIWYG Module

This is the initial release of an XStandard WYSIWYG Module for OpenCms 7+.

You can use the XStandard editor as a replacement of the FCKEditor that comes with OpenCms in case the XHTML produced by FCKeditor does not meet your requirements.

From the XStandard website: "XStandard is the leading standards-compliant plug-in WYSIWYG editor for desktop applications and browser-based content management systems (IE/Firefox/Safari/Opera). The editor generates clean XHTML Strict or 1.1, and uses CSS for formatting, to ensure the clean separation of content from presentation. The editor is keyboard accessible, and markup generated by XStandard meets the most demanding accessibility requirements."

Requirements and Installation:

This module requires a full version of XStandard Pro, not the lite version. You can get a trial pro license from XStandard. Tested with Opencms 7.0.3 / 7.0.4. May or may not work with other versions.


  • XStandard 2.0 integration into OpenCms workplace.
  • Integration with OpenCms image, download, link galleries.

Missing from this release:

  • Integration with XStandard’s web service plugins: spell checker, image gallery, file gallery, etc.
  • Localization.
  • Integration with OpenCms’s WYSIWYG button customization and permissions system.
Module Version: 0.6
Provided By: Paul Boone
License: LGPL
Click here to download (231 kb)

Download OpenCms

  • Try OpenCms 10.5 Beta! This beta release provides a complete look at the features of the next OpenCms generation.

    Click here to download

Upgrade OpenCms

  • Upgrade your existing OpenCms installation to the current stable version 10.0.1 with this easy to use wizard.

    Click here to download

Take the guided tour

Try the OpenCms Live Demo